Arduino controls..

Home Forums Software Suggestions Arduino controls..

This topic contains 10 replies, has 0 voices, and was last updated by Profile photo of -Jeff- -Jeff- 2 years, 8 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #90
    Profile photo of -Jeff-
    -Jeff-
    Participant

    The control works great, but I have a suggestion

    on the buttons is it possible to have 2 text entries for those? especially if I am doing toggle.. it would be nice to have some sort of feedback so i know my touch was accepted.

    I was thinking of using on

    #310
    Profile photo of Eric
    Eric
    Keymaster

    Thanks Jeff
    I hadn’t thought about the two entries, but it should be doable. My first thought was color change. White while off, and green while on. I’ve started down that path already, but could also do the multiple entries later on.

    The “On Sta

    #311
    Profile photo of -Jeff-
    -Jeff-
    Participant

    @eric wrote:

    Thanks Jeff
    I hadn’t thought about the two entries, but it should be doable. My first thought was color change. White while off, and green while on. I’ve started down that path already, but could also do the multiple en

    #301
    Profile photo of Eric
    Eric
    Keymaster

    On startup happens when Autosense starts and makes the first connection the Arduino. I wasn’t exactly sure all the times it should fire so I started here with once. I plan on adding a bunch of hooks when different events happen, and based on the possibl

    #317
    Profile photo of Eric
    Eric
    Keymaster

    I have added multiple colors to the toggle action. damn that was harder than i wanted 😕
    it does work, but there might be some issues. Let me know

    #318
    Profile photo of that_kid
    that_kid
    Participant

    So I just gave this a try on the dev tablet and I see that if yo uhave a button already defined then you need to change the action to get the color chooser to show. I was able to set the high and low color but once set there’s no indication on what to do

    #319
    Profile photo of -Jeff-
    -Jeff-
    Participant

    @that_kid wrote:

    So I just gave this a try on the dev tablet and I see that if yo uhave a button already defined then you need to change the action to get the color chooser to show. I was able to set the high and low color but once se

    #324
    Profile photo of Eric
    Eric
    Keymaster

    @that_kid wrote:

    So I just gave this a try on the dev tablet and I see that if yo uhave a button already defined then you need to change the action to get the color chooser to show. I was able to set the high and low color but once se

    #325
    Profile photo of that_kid
    that_kid
    Participant

    Cool, i was able to remove all those buttons. Now I can re-arrange some buttons in the car as well.

    #328
    Profile photo of Eric
    Eric
    Keymaster

    @-=Jeff=- wrote:

    I have noticed that with other things too.. Any chances of the ‘reload’ button or option in the settings to apply the changes?

    Anything specific that I can fix?

    #330
    Profile photo of Eric
    Eric
    Keymaster

    I found a pretty major bug with the buttons. If you had set up the the IO, then added a button to the homescreen it should have worked. But, if you then went back to edit the master IO for the specified pin, it would delete the database record and add a

    #331
    Profile photo of -Jeff-
    -Jeff-
    Participant

    @eric wrote:

    @-=Jeff=- wrote:
    I have noticed that with other things too.. Any chances of the ‘reload’ button or option in the settings to apply the changes?

    Anything specific that I can fix?[/quote

  • Author
    Posts
  • #90
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    The control works great, but I have a suggestion

    on the buttons is it possible to have 2 text entries for those? especially if I am doing toggle.. it would be nice to have some sort of feedback so i know my touch was accepted.

    I was thinking of using on

    #310
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Thanks Jeff
    I hadn’t thought about the two entries, but it should be doable. My first thought was color change. White while off, and green while on. I’ve started down that path already, but could also do the multiple entries later on.

    The “On Sta

    #311
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    @eric wrote:

    Thanks Jeff
    I hadn’t thought about the two entries, but it should be doable. My first thought was color change. White while off, and green while on. I’ve started down that path already, but could also do the multiple en

    #301
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    On startup happens when Autosense starts and makes the first connection the Arduino. I wasn’t exactly sure all the times it should fire so I started here with once. I plan on adding a bunch of hooks when different events happen, and based on the possibl

    #317
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I have added multiple colors to the toggle action. damn that was harder than i wanted 😕
    it does work, but there might be some issues. Let me know

    #318
    Profile photo of that_kid
    that_kid
    Participant
    • Offline

    So I just gave this a try on the dev tablet and I see that if yo uhave a button already defined then you need to change the action to get the color chooser to show. I was able to set the high and low color but once set there’s no indication on what to do

    #319
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    @that_kid wrote:

    So I just gave this a try on the dev tablet and I see that if yo uhave a button already defined then you need to change the action to get the color chooser to show. I was able to set the high and low color but once se

    #324
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    @that_kid wrote:

    So I just gave this a try on the dev tablet and I see that if yo uhave a button already defined then you need to change the action to get the color chooser to show. I was able to set the high and low color but once se

    #325
    Profile photo of that_kid
    that_kid
    Participant
    • Offline

    Cool, i was able to remove all those buttons. Now I can re-arrange some buttons in the car as well.

    #328
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    @-=Jeff=- wrote:

    I have noticed that with other things too.. Any chances of the ‘reload’ button or option in the settings to apply the changes?

    Anything specific that I can fix?

    #330
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I found a pretty major bug with the buttons. If you had set up the the IO, then added a button to the homescreen it should have worked. But, if you then went back to edit the master IO for the specified pin, it would delete the database record and add a

    #331
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    @eric wrote:

    @-=Jeff=- wrote:
    I have noticed that with other things too.. Any chances of the ‘reload’ button or option in the settings to apply the changes?

    Anything specific that I can fix?[/quote

Viewing 12 posts - 1 through 12 (of 12 total)

The forum ‘Suggestions’ is closed to new topics and replies.