Borders around the buttons

Home Forums Software Suggestions Borders around the buttons

This topic contains 9 replies, has 2 voices, and was last updated by Profile photo of Eric Eric 1 year, 7 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #2276
    Profile photo of Eric
    Eric
    Keymaster

    I received a request to be able to have borders around all of the buttons, making them easier to see.

    If you go to Settings/Appearance/Home Screen, there is a new toggle, called Button Borders.  If you turn it on the borders will appear on all of the buttons.  Currently they use the selected “Highlight Color” chosen in Settings/Appearance.

     

    The latest nightly build has these options.  If you try them, let me know what you think.

    #2278
    Profile photo of idorel77
    idorel77
    Participant

    Hi,

    it is better but i can notice 2 bugs. When turn on the button borders , all icons from home screens is not centred and the borders not fit on buttons with round corners.

    #2279
    Profile photo of idorel77
    idorel77
    Participant

    and something activate and deactivate mute button , is in loop and very fast, and crash the os.

    I try it on 2 systems.

     

    L.E. when i press the volume up 2 times , the volume go up and down (loop) without do anything.

    #2281
    Profile photo of Eric
    Eric
    Keymaster

    Thanks for the feedback.

    Rounded corners is going to be much more difficult, if it’s even possible.  I started with the square, with the intention of doing what I can to round them later on.

    Everything looks centered to me.  Can you provide a screenshot so I can see what’s off on your display?

     

    The mute button.  Are you trying on your UDOO?  If yes, then you’ll need to update your Arduoino firmware.  I’ll put up a Nightly firmware, it’s incomplete and full of bugs too 😉  Otherwise I’ll see if I can reproduce and fix this.

    Also ensure that in Settings/Arduino/Setup Shield/Shield Capabilities that Audio is Off.  If it’s on, and after you turn it off, comes on again, then there may be another issue I’ll need to find.

    #2288
    Profile photo of idorel77
    idorel77
    Participant

    I don’t instaled Arduino firmware. Shuld i ? I don’t have any sensor. On stable version i don’t have that problem with volume.

    Attachments:
    You must be logged in to view attached files.
    #2290
    Profile photo of Eric
    Eric
    Keymaster

    If you haven’t installed the Arduino firmware, and you don’t need it, then don’t. There is a bug somewhere I need to squash.
    The nightly builds have a lot changed with the volume control as it’s the start of support for the shield.
    I’ll look into it, and hopefully have a new one tonight.

    #2300
    Profile photo of Eric
    Eric
    Keymaster

    Do the icons go back to normal if you turn the borders off?

    #2302
    Profile photo of idorel77
    idorel77
    Participant

    yes.

    #2304
    Profile photo of Eric
    Eric
    Keymaster

    I’ve been able to reproduce the problem. It’s an older Android, version 4, issue. I will find a fix and include it in the next nightly.

    #2327
    Profile photo of Eric
    Eric
    Keymaster

    Ok, icon spacing is fixed.  Next I work on the volume problem.  I’ve been able to get similar results in my emulator.  My physical device doesn’t show any symptoms, so I’m not sure yet.

  • Author
    Posts
  • #2276
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I received a request to be able to have borders around all of the buttons, making them easier to see.

    If you go to Settings/Appearance/Home Screen, there is a new toggle, called Button Borders.  If you turn it on the borders will appear on all of the buttons.  Currently they use the selected “Highlight Color” chosen in Settings/Appearance.

     

    The latest nightly build has these options.  If you try them, let me know what you think.

    #2278
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    Hi,

    it is better but i can notice 2 bugs. When turn on the button borders , all icons from home screens is not centred and the borders not fit on buttons with round corners.

    #2279
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    and something activate and deactivate mute button , is in loop and very fast, and crash the os.

    I try it on 2 systems.

     

    L.E. when i press the volume up 2 times , the volume go up and down (loop) without do anything.

    #2281
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Thanks for the feedback.

    Rounded corners is going to be much more difficult, if it’s even possible.  I started with the square, with the intention of doing what I can to round them later on.

    Everything looks centered to me.  Can you provide a screenshot so I can see what’s off on your display?

     

    The mute button.  Are you trying on your UDOO?  If yes, then you’ll need to update your Arduoino firmware.  I’ll put up a Nightly firmware, it’s incomplete and full of bugs too 😉  Otherwise I’ll see if I can reproduce and fix this.

    Also ensure that in Settings/Arduino/Setup Shield/Shield Capabilities that Audio is Off.  If it’s on, and after you turn it off, comes on again, then there may be another issue I’ll need to find.

    #2288
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    I don’t instaled Arduino firmware. Shuld i ? I don’t have any sensor. On stable version i don’t have that problem with volume.

    Attachments:
    You must be logged in to view attached files.
    #2290
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    If you haven’t installed the Arduino firmware, and you don’t need it, then don’t. There is a bug somewhere I need to squash.
    The nightly builds have a lot changed with the volume control as it’s the start of support for the shield.
    I’ll look into it, and hopefully have a new one tonight.

    #2300
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Do the icons go back to normal if you turn the borders off?

    #2302
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    yes.

    #2304
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I’ve been able to reproduce the problem. It’s an older Android, version 4, issue. I will find a fix and include it in the next nightly.

    #2327
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Ok, icon spacing is fixed.  Next I work on the volume problem.  I’ve been able to get similar results in my emulator.  My physical device doesn’t show any symptoms, so I’m not sure yet.

Viewing 10 posts - 1 through 10 (of 10 total)

The forum ‘Suggestions’ is closed to new topics and replies.