Burning Optiboot bootloader to older boards

Home Forums Hardware Arduino Uno Burning Optiboot bootloader to older boards

This topic contains 3 replies, has 0 voices, and was last updated by Profile photo of Eric Eric 2 years, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #174
    Profile photo of Eric
    Eric
    Keymaster

    If you are using an older Duemilanove with an Atmega 328 chip, it likely doesn’t have Optiboot installed, but the default Arduino bootloader. In order to be flashable from within Autosense, you need the Optiboot loader. There are a few ways of burning i

    #448
    Profile photo of that_kid
    that_kid
    Participant

    I do have two Duemilanoves so i can use one to flash the other.

    #451
    Profile photo of Eric
    Eric
    Keymaster

    Remember the Duemilanoves came with an atmega168. so unless you’ve upgraded them to the 328, you won’t be able to flash them optiboot. Also the binary images I have compiled only work with the 328

    #452
    Profile photo of that_kid
    that_kid
    Participant

    The Duemilanoves I have are both 328’s, I guess I lucked up on that.

    #454
    Profile photo of Eric
    Eric
    Keymaster

    Awesome. Burn Optiboot, then Autosense should be able to flash them no problem.

  • Author
    Posts
  • #174
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    If you are using an older Duemilanove with an Atmega 328 chip, it likely doesn’t have Optiboot installed, but the default Arduino bootloader. In order to be flashable from within Autosense, you need the Optiboot loader. There are a few ways of burning i

    #448
    Profile photo of that_kid
    that_kid
    Participant
    • Offline

    I do have two Duemilanoves so i can use one to flash the other.

    #451
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Remember the Duemilanoves came with an atmega168. so unless you’ve upgraded them to the 328, you won’t be able to flash them optiboot. Also the binary images I have compiled only work with the 328

    #452
    Profile photo of that_kid
    that_kid
    Participant
    • Offline

    The Duemilanoves I have are both 328’s, I guess I lucked up on that.

    #454
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Awesome. Burn Optiboot, then Autosense should be able to flash them no problem.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.