Error at startup

Home Forums Software Bug Reports Error at startup

This topic contains 21 replies, has 3 voices, and was last updated by Profile photo of Eric Eric 1 year ago.

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #128
    Profile photo of idorel77
    idorel77
    Participant

    Hi ,
    i have an error at startup ” Pharse error – There was a problem parsing the package”

    I have android 4.4.2 on udoo.

    Can you tell me what is wrong?

    Thanks

    #625
    Profile photo of Eric
    Eric
    Keymaster

    I think that’s usually a sign of an incomplete or corrupted download. Try downloading and installing again.

    #2954
    Profile photo of idorel77
    idorel77
    Participant

    Hi Eric , from the last stable , all new nightly is not working for me.

     

    Tried on udoo 4.4.2 , 5.1, 6.0 and Odroid c2 with android 5.1 .

    I don’t have an error , just ” not installed”

    Do you know why?

     

    Thanks

    #2963
    Profile photo of Eric
    Eric
    Keymaster

    I’m not sure.  I will  see what I can find out for you.

    #2972
    Profile photo of Eric
    Eric
    Keymaster

    I think the issue is due to the way I was checking for Google Play Services.  So I’ve upgraded the checking portion and hopefully it will help.

    #2983
    Profile photo of idorel77
    idorel77
    Participant

    Is the same .
    And if i try to install from market i have ”not compatible” message.

    #2985
    Profile photo of Eric
    Eric
    Keymaster

    Ok.  Some basic questions:

    – You have enough free space

    – You’ve downloaded the file again

    – The MD5 sum for the latest nighly is 6cb603634ef923ba1b92d977bea702d4 – I will add this to the download page to show automatically

    – Unknown sources are enabled

     

    #2989
    Profile photo of idorel77
    idorel77
    Participant

    Yes i did all this.

    Working only on my phone nexus 5.

    But not working on udoo and odroid and 3 dif OS.

    I something about compatibility.

    #2991
    Profile photo of Eric
    Eric
    Keymaster

    Has anybody else experienced issues with Autosense not working on those platforms?  I’ve never had issue with my Udoo, and I don’t have an Odroid.

    #2996
    Profile photo of Eric
    Eric
    Keymaster
    #3000
    Profile photo of idorel77
    idorel77
    Participant

    Not working! and i don’t have all hat option.

    #3002
    Profile photo of Eric
    Eric
    Keymaster

    Two questions, how are you trying to install Autosense?  Are you downloading it on your computer first, then transferring it over, or are you downloading it directly on your Android device?

    Do you have adb installed on your computer?

    If you do, you could try installing with the terminal.

    First, on the device make sure Enable USB Debugging

     

    To enable USB debugging, you need to enable Developer Option first.

    To enable “Developer option” go to, Settings, scroll down and tap on About Phone and then tap seven times on the “Build Number”. You should see a “You are now a developer” message on the screen.

    Next, go to Settings again, scroll down and tap on Developer Options. Under developer options, tap on USB debugging and enable it.

     

    Once that is done, download the apk to your computer, and from the terminal, type “adb install /path/to/autosenseapp.apk”

    #3006
    Profile photo of idorel77
    idorel77
    Participant

    Hi Eric i will try, but i don’t have any problem with other apps.
    I used many methods to download from pc , from board different applications.

    I think is something about compatibility , because like i told you , if i try to install by play store , it says ”no compatibility with your device”
    and i try it 2 boards and 3 OS’s with clean install…

    #3009
    Profile photo of Eric
    Eric
    Keymaster

    I just really don’t know what the issue is.  I don’t think anything has changed regarding compatibility at all.  Maybe I’ll try building an old version and send it to you, see if that installs.

    #3035
    Profile photo of idorel77
    idorel77
    Participant

    with adb install, maybe this help:

    192-168-0-104:Odroid dorel$ adb install Autosense-nightly-armv7.apk
    7905 KB/s (5533486 bytes in 0.683s)
    pkg: /data/local/tmp/Autosense-nightly-armv7.apk
    Failure [INSTALL_FAILED_MISSING_SHARED_LIBRARY]

  • Author
    Posts
  • #128
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    Hi ,
    i have an error at startup ” Pharse error – There was a problem parsing the package”

    I have android 4.4.2 on udoo.

    Can you tell me what is wrong?

    Thanks

    #625
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I think that’s usually a sign of an incomplete or corrupted download. Try downloading and installing again.

    #2954
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    Hi Eric , from the last stable , all new nightly is not working for me.

     

    Tried on udoo 4.4.2 , 5.1, 6.0 and Odroid c2 with android 5.1 .

    I don’t have an error , just ” not installed”

    Do you know why?

     

    Thanks

    #2963
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I’m not sure.  I will  see what I can find out for you.

    #2972
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I think the issue is due to the way I was checking for Google Play Services.  So I’ve upgraded the checking portion and hopefully it will help.

    #2983
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    Is the same .
    And if i try to install from market i have ”not compatible” message.

    #2985
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Ok.  Some basic questions:

    – You have enough free space

    – You’ve downloaded the file again

    – The MD5 sum for the latest nighly is 6cb603634ef923ba1b92d977bea702d4 – I will add this to the download page to show automatically

    – Unknown sources are enabled

     

    #2989
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    Yes i did all this.

    Working only on my phone nexus 5.

    But not working on udoo and odroid and 3 dif OS.

    I something about compatibility.

    #2991
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Has anybody else experienced issues with Autosense not working on those platforms?  I’ve never had issue with my Udoo, and I don’t have an Odroid.

    #2996
    Profile photo of Eric
    Eric
    Keymaster
    • Offline
    #3000
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    Not working! and i don’t have all hat option.

    #3002
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Two questions, how are you trying to install Autosense?  Are you downloading it on your computer first, then transferring it over, or are you downloading it directly on your Android device?

    Do you have adb installed on your computer?

    If you do, you could try installing with the terminal.

    First, on the device make sure Enable USB Debugging

     

    To enable USB debugging, you need to enable Developer Option first.

    To enable “Developer option” go to, Settings, scroll down and tap on About Phone and then tap seven times on the “Build Number”. You should see a “You are now a developer” message on the screen.

    Next, go to Settings again, scroll down and tap on Developer Options. Under developer options, tap on USB debugging and enable it.

     

    Once that is done, download the apk to your computer, and from the terminal, type “adb install /path/to/autosenseapp.apk”

    #3006
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    Hi Eric i will try, but i don’t have any problem with other apps.
    I used many methods to download from pc , from board different applications.

    I think is something about compatibility , because like i told you , if i try to install by play store , it says ”no compatibility with your device”
    and i try it 2 boards and 3 OS’s with clean install…

    #3009
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I just really don’t know what the issue is.  I don’t think anything has changed regarding compatibility at all.  Maybe I’ll try building an old version and send it to you, see if that installs.

    #3035
    Profile photo of idorel77
    idorel77
    Participant
    • Offline

    with adb install, maybe this help:

    192-168-0-104:Odroid dorel$ adb install Autosense-nightly-armv7.apk
    7905 KB/s (5533486 bytes in 0.683s)
    pkg: /data/local/tmp/Autosense-nightly-armv7.apk
    Failure [INSTALL_FAILED_MISSING_SHARED_LIBRARY]

Viewing 15 posts - 1 through 15 (of 22 total)

You must be logged in to reply to this topic.