Arduino Due on power on?

Home Forums Hardware Arduino Due Arduino Due on power on?

This topic contains 17 replies, has 0 voices, and was last updated by Profile photo of Eric Eric 2 years, 3 months ago.

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
    Posts
  • #165
    Profile photo of -Jeff-
    -Jeff-
    Participant

    How is the connection on power up?

    I am going to connect this in the car once I get the EEPROM.. I forget which USB I should be connecting to though.

    I hope it works well with the Android radio I have, I seem to recall that it connected okay before, bu

    #819
    Profile photo of Eric
    Eric
    Keymaster

    You need to use an OTG cable plugged into the Native USB port. You also need to power the Arduino. You have a couple of options. You can use a ‘Y’ OTG cable [url=http://www.amazon.ca/Importer520-Micro-Cable-Power-Galaxy/dp/B00CXAC1ZW:1xz03z

    #820
    Profile photo of -Jeff-
    -Jeff-
    Participant

    @eric wrote:

    You need to use an OTG cable plugged into the Native USB port. You also need to power the Arduino. You have a couple of options. You can use a ‘Y’ OTG cable [url=http://www.amazon.ca/Importer520-Micro-Cable-

    #821
    Profile photo of Eric
    Eric
    Keymaster

    It should be the standard USB you’ll use. Imagine the Arduino to be a computer and think that you’re plugging the radio into the computer. OTG is needed to give you a USB A female socket.

    #822
    Profile photo of -Jeff-
    -Jeff-
    Participant

    @eric wrote:

    It should be the standard USB you’ll use. Imagine the Arduino to be a computer and think that you’re plugging the radio into the computer. OTG is needed to give you a USB A female socket.

    yeah I am sure

    #823
    Profile photo of -Jeff-
    -Jeff-
    Participant

    Ok I had it connected

    Android sees it as a USB Accessory correct?

    I can go into the Arduino menu in Autosense, it sees the DUE.. I assign a Output as a toggle..

    It worked once, but then I had a issue with removing the Home screen buttons and the settin

    #824
    Profile photo of Eric
    Eric
    Keymaster

    You’ll need to reflash the Due with the latest firmware which I haven’t release yet. And yes, you’ll also need the EEPROM for it to work.

    I have it working on my Nexus 7 and a Due on my test bench, and on my UDOO, so two physical devices isn’t an issue.

    #825
    Profile photo of Eric
    Eric
    Keymaster

    I can push the latest nightly right now which will include all the latest code on the Android side, and I’ll put up a snapshot of the Due firmware you can use to play with… hang tight a few minutes

    #791
    Profile photo of -Jeff-
    -Jeff-
    Participant

    @eric wrote:

    I can push the latest nightly right now which will include all the latest code on the Android side, and I’ll put up a snapshot of the Due firmware you can use to play with… hang tight a few minutes

    No

    #826
    Profile photo of Eric
    Eric
    Keymaster

    Arduino tools in place. Follow this guide. Autosense nightly still building, will be up soon.

    #827
    Profile photo of -Jeff-
    -Jeff-
    Participant

    @eric wrote:

    Arduino tools in place. Follow this guide. Autosense nightly still building, will be up soon.

    #828
    Profile photo of Eric
    Eric
    Keymaster

    The bin file is brand new. Still a work in progress but very different than before.

    #829
    Profile photo of Eric
    Eric
    Keymaster

    There we go. I needed up update my server for the build to finish, but it’s all good to go.
    If you try the latest with the Arduino let me know how it goes.

    #832
    Profile photo of -Jeff-
    -Jeff-
    Participant

    this does not work unless I swap out the true switch for false

    4) Type the command “./bossac –port=tty.usbmodemfd12211 -U true -e -w -v -b master.cpp.bin -R”

    #833
    Profile photo of Eric
    Eric
    Keymaster

    I’ll put a note. According to the man pages the ‘U’ switch is for USB port auto-detection. I guess in your case it worked, in mine it didn’t.

  • Author
    Posts
  • #165
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    How is the connection on power up?

    I am going to connect this in the car once I get the EEPROM.. I forget which USB I should be connecting to though.

    I hope it works well with the Android radio I have, I seem to recall that it connected okay before, bu

    #819
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    You need to use an OTG cable plugged into the Native USB port. You also need to power the Arduino. You have a couple of options. You can use a ‘Y’ OTG cable [url=http://www.amazon.ca/Importer520-Micro-Cable-Power-Galaxy/dp/B00CXAC1ZW:1xz03z

    #820
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    @eric wrote:

    You need to use an OTG cable plugged into the Native USB port. You also need to power the Arduino. You have a couple of options. You can use a ‘Y’ OTG cable [url=http://www.amazon.ca/Importer520-Micro-Cable-

    #821
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    It should be the standard USB you’ll use. Imagine the Arduino to be a computer and think that you’re plugging the radio into the computer. OTG is needed to give you a USB A female socket.

    #822
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    @eric wrote:

    It should be the standard USB you’ll use. Imagine the Arduino to be a computer and think that you’re plugging the radio into the computer. OTG is needed to give you a USB A female socket.

    yeah I am sure

    #823
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    Ok I had it connected

    Android sees it as a USB Accessory correct?

    I can go into the Arduino menu in Autosense, it sees the DUE.. I assign a Output as a toggle..

    It worked once, but then I had a issue with removing the Home screen buttons and the settin

    #824
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    You’ll need to reflash the Due with the latest firmware which I haven’t release yet. And yes, you’ll also need the EEPROM for it to work.

    I have it working on my Nexus 7 and a Due on my test bench, and on my UDOO, so two physical devices isn’t an issue.

    #825
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I can push the latest nightly right now which will include all the latest code on the Android side, and I’ll put up a snapshot of the Due firmware you can use to play with… hang tight a few minutes

    #791
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    @eric wrote:

    I can push the latest nightly right now which will include all the latest code on the Android side, and I’ll put up a snapshot of the Due firmware you can use to play with… hang tight a few minutes

    No

    #826
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Arduino tools in place. Follow this guide. Autosense nightly still building, will be up soon.

    #827
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    @eric wrote:

    Arduino tools in place. Follow this guide. Autosense nightly still building, will be up soon.

    #828
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    The bin file is brand new. Still a work in progress but very different than before.

    #829
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    There we go. I needed up update my server for the build to finish, but it’s all good to go.
    If you try the latest with the Arduino let me know how it goes.

    #832
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    this does not work unless I swap out the true switch for false

    4) Type the command “./bossac –port=tty.usbmodemfd12211 -U true -e -w -v -b master.cpp.bin -R”

    #833
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I’ll put a note. According to the man pages the ‘U’ switch is for USB port auto-detection. I guess in your case it worked, in mine it didn’t.

Viewing 15 posts - 1 through 15 (of 19 total)

You must be logged in to reply to this topic.