Finally got HD to work

Home Forums Autosense General Discussion Finally got HD to work

This topic contains 10 replies, has 2 voices, and was last updated by Profile photo of -Jeff- -Jeff- 1 year, 4 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #2692
    Profile photo of Eric
    Eric
    Keymaster

    So I’ve FINALLY got my radio to tune to HD using the stock controller. This is huge for me. I should now be able to finally figure out how this damn thing works.

    #2693
    Profile photo of -Jeff-
    -Jeff-
    Participant

    Sorry Eric, i needed to do some testing for you, but I have been swamped with stuff.. I am in midst of trying to get the top end of my motor back together…

    Glad you got HD working.. looking forward to some more updates

    #2694
    Profile photo of Eric
    Eric
    Keymaster

    No worries about the testing. I’ve been swamped with stuff too.. thus the lack of updates lately.
    I have got sub channels working. I’m not quite sure the best way to implement it though. Still playing with ideas. And presets somewhat work. The sub channels don’t though.

    #2695
    Profile photo of -Jeff-
    -Jeff-
    Participant

    Sub channel presets? I doubt those were avail on the stock control. How would it tune if you could not get HD and it was stored?

    #2696
    Profile photo of Eric
    Eric
    Keymaster

    Sub channel presets are available on stock. The stock unit first tunes to the main channel, and once it locks on, it switches to the sub channel. Shouldn’t be too hard. But if the signal isn’t available it will have to issue a notification some how..

    #2698
    Profile photo of Eric
    Eric
    Keymaster

    I’ve made some more progress.
    The nightly I just pushed has some new features for HD radio users.

    Once you tune to a station, if HD is available it will auto tune to it, and show the radio callsign and number of sub channels available below. Once this info is shown, and you hear the change from analog to HD, you can press the tune+/tune- buttons to switch between the sub channels. Once you hit the end it will go to the next analog station. I only have one HD station available, and it has one sub channel. So if you have more, please test.

    Presets do NOT work yet. If you save an HD preset, it will show up with the HD label, but pressing the button won’t tune to anything yet, it will just fail. I’ll get to that soon.

    Also, the radio info for sub channels isn’t working yet.

    • This reply was modified 1 year, 4 months ago by Profile photo of Eric Eric.
    #2701
    Profile photo of -Jeff-
    -Jeff-
    Participant

    Awesome Eric!!  I need to get set-up for testing again..

     

    Can I order just a cable from you? the way my tuner is mounted, the cable is not quite that easy to remove. I plan on the Arduino to be easier to access

    #2703
    Profile photo of Eric
    Eric
    Keymaster

    Yeah I can make and send you a cable. How long would you like it?

    #2705
    Profile photo of Eric
    Eric
    Keymaster

    So I’ve got the text being displayed mostly correctly now. It changes properly with substations and between non hd stations too. You will need a new Arduino firmware, which I’ve posted.

    #2706
    Profile photo of Eric
    Eric
    Keymaster

    OK. Presets should be working. It might need some tweaking, but it seems to work for me.
    If you tune to a sub channel, say HD2, save it as a preset. Then change to any other station, and then click the new preset. The radio will tune to the analog channel first, wait for HD, then switch to the sub. So you’ll hear the main stuff for a few seconds while HD locks on.

    Seems to work well. I’ll see what I can do to make it even better. But I’m happy with the progress so far 🙂

    #2708
    Profile photo of -Jeff-
    -Jeff-
    Participant

    3 feet will be fine.. just like the one I have

  • Author
    Posts
  • #2692
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    So I’ve FINALLY got my radio to tune to HD using the stock controller. This is huge for me. I should now be able to finally figure out how this damn thing works.

    #2693
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    Sorry Eric, i needed to do some testing for you, but I have been swamped with stuff.. I am in midst of trying to get the top end of my motor back together…

    Glad you got HD working.. looking forward to some more updates

    #2694
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    No worries about the testing. I’ve been swamped with stuff too.. thus the lack of updates lately.
    I have got sub channels working. I’m not quite sure the best way to implement it though. Still playing with ideas. And presets somewhat work. The sub channels don’t though.

    #2695
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    Sub channel presets? I doubt those were avail on the stock control. How would it tune if you could not get HD and it was stored?

    #2696
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Sub channel presets are available on stock. The stock unit first tunes to the main channel, and once it locks on, it switches to the sub channel. Shouldn’t be too hard. But if the signal isn’t available it will have to issue a notification some how..

    #2698
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I’ve made some more progress.
    The nightly I just pushed has some new features for HD radio users.

    Once you tune to a station, if HD is available it will auto tune to it, and show the radio callsign and number of sub channels available below. Once this info is shown, and you hear the change from analog to HD, you can press the tune+/tune- buttons to switch between the sub channels. Once you hit the end it will go to the next analog station. I only have one HD station available, and it has one sub channel. So if you have more, please test.

    Presets do NOT work yet. If you save an HD preset, it will show up with the HD label, but pressing the button won’t tune to anything yet, it will just fail. I’ll get to that soon.

    Also, the radio info for sub channels isn’t working yet.

    • This reply was modified 1 year, 4 months ago by Profile photo of Eric Eric.
    #2701
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    Awesome Eric!!  I need to get set-up for testing again..

     

    Can I order just a cable from you? the way my tuner is mounted, the cable is not quite that easy to remove. I plan on the Arduino to be easier to access

    #2703
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Yeah I can make and send you a cable. How long would you like it?

    #2705
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    So I’ve got the text being displayed mostly correctly now. It changes properly with substations and between non hd stations too. You will need a new Arduino firmware, which I’ve posted.

    #2706
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    OK. Presets should be working. It might need some tweaking, but it seems to work for me.
    If you tune to a sub channel, say HD2, save it as a preset. Then change to any other station, and then click the new preset. The radio will tune to the analog channel first, wait for HD, then switch to the sub. So you’ll hear the main stuff for a few seconds while HD locks on.

    Seems to work well. I’ll see what I can do to make it even better. But I’m happy with the progress so far 🙂

    #2708
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    3 feet will be fine.. just like the one I have

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.