Problem Getting to App Settings

Home Forums Autosense General Discussion Problem Getting to App Settings

This topic contains 20 replies, has 2 voices, and was last updated by Profile photo of Eric Eric 2 years, 2 months ago.

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #1974
    Profile photo of dmh
    dmh
    Participant

    Not sure if I’m missing something or I have something set wrong.

    Here’s my setup:
    4.2.2 on a Riko stick with Autosense 1.0.
    Arduino Due (no eeprom yet).
    Arduino files installed per the download page. (android recognized it).

    When I click on the Settings option on the app. it sends me back to the android launch page. At one time it gave me an option “Complete action using”- Autosense or Launcher with the choices of Always or Just once. I’ve tried all different combinations but have never been able to get to the apps settings.

    Any ideas?

    Attachments:
    You must be logged in to view attached files.
    #1976
    Profile photo of Eric
    Eric
    Keymaster

    4.2.2 or 4.4.2?
    You’re using the latest stable version?
    Try without the Due first, just to make sure everything works.

    The Settings is a button for another fragment, it should just slide up and show the options. The Complete action dialog is for pressing the home button, because AutoSense is a home screen replacement that option pops up when home is pressed.

    Really, clicking that icon on the screen should just work…

    #1979
    Profile photo of dmh
    dmh
    Participant

    4.2.2
    Yes, latest stable version. (downloaded it about 2 weeks ago)
    I get the same thing with the Due unplugged. I open the app, click on settings and it goes to the android launch (home) page.

    I have the stick plugged into a monitor and I’m controlling it with a mouse. would that have anything to do with it?

    #1980
    Profile photo of Eric
    Eric
    Keymaster

    The mouse shouldn’t make a difference. Have you set AutoSense to be the home screen?

    #1981
    Profile photo of dmh
    dmh
    Participant

    Not sure, where would I check that at and what should it be set at?

    #1982
    Profile photo of Eric
    Eric
    Keymaster

    When you click the home button and it asks if you want AutoSense or launcher select AutoSense and check always. Otherwise in settings under apps can select the default launcher.

    #1983
    Profile photo of Eric
    Eric
    Keymaster

    I am unable to reproduce your problem. And nobody else has ever had it that I know of. So we’re going to have to really work on this together.
    So a few more questions, can you try the latest nightly. But before you install it completely remove AutoSense. If that doesn’t work maybe we can video chat so you can show me exactly what’s happening and maybe I can find a combination that reproduces the issue.

    #1984
    Profile photo of dmh
    dmh
    Participant

    Thanks for the help and suggestions Eric.

    I gave up on it last night but I’ve been playing with it a little more this morning.

    “When you click the home button and it asks if you want AutoSense or launcher select AutoSense and check always. Otherwise in settings under apps can select the default launcher.”

    Your talking about the android home button right? (Not the one in the app?)

    I tried that but it doesn’t save the setting after I click on settings in the app. If I don’t click on settings (in the app) it seems to take. Once I click on settings it clears the Launch By Default in the app settings.

    I also noticed, when I’m in autosense and click on settings it will take me back to where i was previously. If I was previously on android settings, it will take me back there. If I was previously on Gmail it will open that up. If I was previously on the android home screen it will send me back there.

    I Also tried:
    Uninstalling autosense and then installed the nightly build. Same problem
    Did a factory data reset and installed the nightly build. Same problem

    If You have any other ideas please throw’em at me. 🙂

    I’ll have to see if I can get the video chat set up.

    #1985
    Profile photo of Eric
    Eric
    Keymaster

    I wonder if it’s a 4.2.2 issue, as it’s been a long time since I’ve used Jelly Bean. I don’t have any devices with that version still.
    The behaviour you’re saying is so odd, I’ve never seen it.

    As for the chat, I sent you a message (Under the My Account tab in the nav bar / Messages), if you follow that link we can chat with nothing for you to setup.

    #1986
    Profile photo of Eric
    Eric
    Keymaster

    So I setup an emulator running 4.2.2 and I’ve found one issue, it’s not the settings button. There must be something specific with your device. I’ll keep looking.

    #1987
    Profile photo of Eric
    Eric
    Keymaster

    I think I found the problem. Does your device have bluetooth? I found an error that only happens when you don’t have bluetooth. When launching the Settings it would crash, and in your case I believe just show the launcher dialog again. So I’ve fixed it and will push a new nightly ASAP.

    #1988
    Profile photo of Eric
    Eric
    Keymaster

    OK, it’s building now. So if you get this in the next while, on the Downloads page, if the badge says Failed, don’t download it, nothing has changed. If it says Success, then the new version was successfully built and should work.

    #1989
    Profile photo of dmh
    dmh
    Participant

    Amazing! No, it doesn’t have bluetooth.

    Looking forward to the new version!

    Thanks

    #1990
    Profile photo of Eric
    Eric
    Keymaster

    OK, I believe that will be the issue then. The build failed, so I’m looking into why. I’ll be building again soon.

    #1991
    Profile photo of Eric
    Eric
    Keymaster

    Ok. So finally the build has passed. It’s now uploading the new apk. Should be up in a few minutes. You’ll have to redownload the nightly, but you shouldn’t have to remove the existing version, although if you have problems that would be the first thing I try.

  • Author
    Posts
  • #1974
    Profile photo of dmh
    dmh
    Participant
    • Offline

    Not sure if I’m missing something or I have something set wrong.

    Here’s my setup:
    4.2.2 on a Riko stick with Autosense 1.0.
    Arduino Due (no eeprom yet).
    Arduino files installed per the download page. (android recognized it).

    When I click on the Settings option on the app. it sends me back to the android launch page. At one time it gave me an option “Complete action using”- Autosense or Launcher with the choices of Always or Just once. I’ve tried all different combinations but have never been able to get to the apps settings.

    Any ideas?

    Attachments:
    You must be logged in to view attached files.
    #1976
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    4.2.2 or 4.4.2?
    You’re using the latest stable version?
    Try without the Due first, just to make sure everything works.

    The Settings is a button for another fragment, it should just slide up and show the options. The Complete action dialog is for pressing the home button, because AutoSense is a home screen replacement that option pops up when home is pressed.

    Really, clicking that icon on the screen should just work…

    #1979
    Profile photo of dmh
    dmh
    Participant
    • Offline

    4.2.2
    Yes, latest stable version. (downloaded it about 2 weeks ago)
    I get the same thing with the Due unplugged. I open the app, click on settings and it goes to the android launch (home) page.

    I have the stick plugged into a monitor and I’m controlling it with a mouse. would that have anything to do with it?

    #1980
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    The mouse shouldn’t make a difference. Have you set AutoSense to be the home screen?

    #1981
    Profile photo of dmh
    dmh
    Participant
    • Offline

    Not sure, where would I check that at and what should it be set at?

    #1982
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    When you click the home button and it asks if you want AutoSense or launcher select AutoSense and check always. Otherwise in settings under apps can select the default launcher.

    #1983
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I am unable to reproduce your problem. And nobody else has ever had it that I know of. So we’re going to have to really work on this together.
    So a few more questions, can you try the latest nightly. But before you install it completely remove AutoSense. If that doesn’t work maybe we can video chat so you can show me exactly what’s happening and maybe I can find a combination that reproduces the issue.

    #1984
    Profile photo of dmh
    dmh
    Participant
    • Offline

    Thanks for the help and suggestions Eric.

    I gave up on it last night but I’ve been playing with it a little more this morning.

    “When you click the home button and it asks if you want AutoSense or launcher select AutoSense and check always. Otherwise in settings under apps can select the default launcher.”

    Your talking about the android home button right? (Not the one in the app?)

    I tried that but it doesn’t save the setting after I click on settings in the app. If I don’t click on settings (in the app) it seems to take. Once I click on settings it clears the Launch By Default in the app settings.

    I also noticed, when I’m in autosense and click on settings it will take me back to where i was previously. If I was previously on android settings, it will take me back there. If I was previously on Gmail it will open that up. If I was previously on the android home screen it will send me back there.

    I Also tried:
    Uninstalling autosense and then installed the nightly build. Same problem
    Did a factory data reset and installed the nightly build. Same problem

    If You have any other ideas please throw’em at me. 🙂

    I’ll have to see if I can get the video chat set up.

    #1985
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I wonder if it’s a 4.2.2 issue, as it’s been a long time since I’ve used Jelly Bean. I don’t have any devices with that version still.
    The behaviour you’re saying is so odd, I’ve never seen it.

    As for the chat, I sent you a message (Under the My Account tab in the nav bar / Messages), if you follow that link we can chat with nothing for you to setup.

    #1986
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    So I setup an emulator running 4.2.2 and I’ve found one issue, it’s not the settings button. There must be something specific with your device. I’ll keep looking.

    #1987
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I think I found the problem. Does your device have bluetooth? I found an error that only happens when you don’t have bluetooth. When launching the Settings it would crash, and in your case I believe just show the launcher dialog again. So I’ve fixed it and will push a new nightly ASAP.

    #1988
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    OK, it’s building now. So if you get this in the next while, on the Downloads page, if the badge says Failed, don’t download it, nothing has changed. If it says Success, then the new version was successfully built and should work.

    #1989
    Profile photo of dmh
    dmh
    Participant
    • Offline

    Amazing! No, it doesn’t have bluetooth.

    Looking forward to the new version!

    Thanks

    #1990
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    OK, I believe that will be the issue then. The build failed, so I’m looking into why. I’ll be building again soon.

    #1991
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Ok. So finally the build has passed. It’s now uploading the new apk. Should be up in a few minutes. You’ll have to redownload the nightly, but you shouldn’t have to remove the existing version, although if you have problems that would be the first thing I try.

Viewing 15 posts - 1 through 15 (of 21 total)

You must be logged in to reply to this topic.