Shield options questions

Home Forums Hardware AutoSense Shield Shield options questions

This topic contains 23 replies, has 3 voices, and was last updated by Profile photo of Eric Eric 3 years, 11 months ago.

Viewing 9 posts - 16 through 24 (of 24 total)
  • Author
    Posts
  • #2003
    Profile photo of Eric
    Eric
    Keymaster

    I put them in yesterday but my build server has been acting up, as in not working, so no. I’m still working on getting a successful build.
    Once the build actually works then all three intents (vol up, down and mute) try 3 different methods of executing the intent. So if you can put the same intent in all three configs and let me know if any of them work then I’ll switch the code so they all work the same.

    #2004
    Profile photo of -Jeff-
    -Jeff-
    Participant

    Cool.. I am in no rush, if that other build had them I would try it.. I can wait.. Did you get the new shields yet? i want to buy one, but need to save some more $$ for it

    #2005
    Profile photo of Eric
    Eric
    Keymaster

    I’m still waiting for the PCB’s to arrive. The manufacturer says they’ve been made, now we wait for them to be shipped.
    Hopefully today I’ll get the build server to work again and I’ll get the new version out for you to try.

    #2008
    Profile photo of Eric
    Eric
    Keymaster

    So after messing around with my build server ALL DAY and getting NOWHERE I’ve manually built a new nightly. It’s been uploaded and should work.
    If you can try adding the same intent for volume up, down and mute and report back if any of them work that would be great. Hopefully one of them does, and then I can switch all three to the same code.

    #2009
    Profile photo of -Jeff-
    -Jeff-
    Participant

    Okay, Hopefully I will have some time to try it this evening when I get home

    #2010
    Profile photo of -Jeff-
    -Jeff-
    Participant

    Tried it.. none of the commands work.. same thing.. as before, although now, the message pops up twice for every one button press

    #2011
    Profile photo of Eric
    Eric
    Keymaster

    BAHHH. OK. I’ll keep trying. As for the double messages, that’s very weird. I don’t see why that would happen.

    #2012
    Profile photo of that_kid
    that_kid
    Participant

    any progress using the Due on a usb host port?

    #2013
    Profile photo of Eric
    Eric
    Keymaster

    Working on it. It’s appearing in Android, but I’ve not got serial communication working yet. I’m starting to remember why I switched to accessory mode in the first place. Debugging is an extreme pain in the ass.

  • Author
    Posts
  • #2003
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I put them in yesterday but my build server has been acting up, as in not working, so no. I’m still working on getting a successful build.
    Once the build actually works then all three intents (vol up, down and mute) try 3 different methods of executing the intent. So if you can put the same intent in all three configs and let me know if any of them work then I’ll switch the code so they all work the same.

    #2004
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    Cool.. I am in no rush, if that other build had them I would try it.. I can wait.. Did you get the new shields yet? i want to buy one, but need to save some more $$ for it

    #2005
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    I’m still waiting for the PCB’s to arrive. The manufacturer says they’ve been made, now we wait for them to be shipped.
    Hopefully today I’ll get the build server to work again and I’ll get the new version out for you to try.

    #2008
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    So after messing around with my build server ALL DAY and getting NOWHERE I’ve manually built a new nightly. It’s been uploaded and should work.
    If you can try adding the same intent for volume up, down and mute and report back if any of them work that would be great. Hopefully one of them does, and then I can switch all three to the same code.

    #2009
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    Okay, Hopefully I will have some time to try it this evening when I get home

    #2010
    Profile photo of -Jeff-
    -Jeff-
    Participant
    • Offline

    Tried it.. none of the commands work.. same thing.. as before, although now, the message pops up twice for every one button press

    #2011
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    BAHHH. OK. I’ll keep trying. As for the double messages, that’s very weird. I don’t see why that would happen.

    #2012
    Profile photo of that_kid
    that_kid
    Participant
    • Offline

    any progress using the Due on a usb host port?

    #2013
    Profile photo of Eric
    Eric
    Keymaster
    • Offline

    Working on it. It’s appearing in Android, but I’ve not got serial communication working yet. I’m starting to remember why I switched to accessory mode in the first place. Debugging is an extreme pain in the ass.

Viewing 9 posts - 16 through 24 (of 24 total)

You must be logged in to reply to this topic.